import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[0-9]).{1,10}$";
final String string = "\n"
+ "1\n"
+ "2\n"
+ "1234567890\n"
+ "12345678901\n"
+ "a\n"
+ "abcd\n"
+ "abcdefgh\n"
+ "ABC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}