import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=[a-zA-Z]*\\d[a-zA-Z]*)([a-zA-Z0-9]{5}\\b)";
final String string = "1 digit and all letters are different\n"
+ "For example: 1abcd\n"
+ "1 digit, 2 letters are equal and the rest are different\n"
+ "For example: a2acd\n"
+ "1 digit, 3 letters are equal and the rest are different\n"
+ "For example: aa3ad\n"
+ "1 digit, 4 letters are equal\n"
+ "For example: aa5aa\n"
+ "1 digit, 2 letters are equal and two different other letters are equal\n"
+ "For example: 1aabb\n\n"
+ "Add a second \\b if you want to reject 1abcdggg\n\n"
+ "\\b(?=[a-zA-Z]*\\d[a-zA-Z]*)([a-zA-Z0-9]{5}\\b)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}