$re = '/\b(?=[a-zA-Z]*\d[a-zA-Z]*)([a-zA-Z0-9]{5}\b)/m';
$str = '1 digit and all letters are different
For example: 1abcd
1 digit, 2 letters are equal and the rest are different
For example: a2acd
1 digit, 3 letters are equal and the rest are different
For example: aa3ad
1 digit, 4 letters are equal
For example: aa5aa
1 digit, 2 letters are equal and two different other letters are equal
For example: 1aabb
Add a second \\b if you want to reject 1abcdggg
\\b(?=[a-zA-Z]*\\d[a-zA-Z]*)([a-zA-Z0-9]{5}\\b)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);