# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?=[a-zA-Z]*\d[a-zA-Z]*)([a-zA-Z0-9]{5}\b)"
test_str = ("1 digit and all letters are different\n"
"For example: 1abcd\n"
"1 digit, 2 letters are equal and the rest are different\n"
"For example: a2acd\n"
"1 digit, 3 letters are equal and the rest are different\n"
"For example: aa3ad\n"
"1 digit, 4 letters are equal\n"
"For example: aa5aa\n"
"1 digit, 2 letters are equal and two different other letters are equal\n"
"For example: 1aabb\n\n"
"Add a second \\b if you want to reject 1abcdggg\n\n"
"\\b(?=[a-zA-Z]*\\d[a-zA-Z]*)([a-zA-Z0-9]{5}\\b)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.