import Foundation
let pattern = #"\b(?=[a-zA-Z]*\d[a-zA-Z]*)([a-zA-Z0-9]{5}\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 digit and all letters are different
For example: 1abcd
1 digit, 2 letters are equal and the rest are different
For example: a2acd
1 digit, 3 letters are equal and the rest are different
For example: aa3ad
1 digit, 4 letters are equal
For example: aa5aa
1 digit, 2 letters are equal and two different other letters are equal
For example: 1aabb
Add a second \b if you want to reject 1abcdggg
\b(?=[a-zA-Z]*\d[a-zA-Z]*)([a-zA-Z0-9]{5}\b)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)