package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+61(?P<test>1800)?(?(test)\d{6}|\d{9})$`)
var str = `+611800123456
+61123456789
+61180012345
+6112345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}