import re
regex = re.compile(r"^\+61(?P<test>1800)?(?(test)\d{6}|\d{9})$", flags=re.MULTILINE)
test_str = ("+611800123456\n"
"+61123456789\n\n"
"+61180012345\n"
"+6112345678")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")