// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+61(?P<test>1800)?(?(test)\d{6}|\d{9})$").unwrap();
let string = "+611800123456
+61123456789
+61180012345
+6112345678";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}