re = /^\+61(?P<test>1800)?(?(test)\d{6}|\d{9})$/m
str = '+611800123456
+61123456789
+61180012345
+6112345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end