using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[.+?\]\(.+?\)";
string input = @"[Click here for more info](https://example.com)
[Visit our website!](https://my.long.domain/path/to/something)[Latest news](https://news.site.com/2024/01/article)
[Download PDF](https://files.example.com/doc.pdf)
[Contact Support](mailto:support@example.com)
[Empty link]()
[Multiple words in link text](https://example.com/page)
[Special Ch@racters!](https://example.com/special)
[Nested [Brackets]](https://example.com)
[Numbers 123](https://123.example.com)
Here's some text [and another] thing (hello)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}