import Foundation
let pattern = #"\[.+?\]\(.+?\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[Click here for more info](https://example.com)
[Visit our website!](https://my.long.domain/path/to/something)[Latest news](https://news.site.com/2024/01/article)
[Download PDF](https://files.example.com/doc.pdf)
[Contact Support](mailto:support@example.com)
[Empty link]()
[Multiple words in link text](https://example.com/page)
[Special Ch@racters!](https://example.com/special)
[Nested [Brackets]](https://example.com)
[Numbers 123](https://123.example.com)
Here's some text [and another] thing (hello)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)