use strict;
my $str = '[Click here for more info](https://example.com)
[Visit our website!](https://my.long.domain/path/to/something)[Latest news](https://news.site.com/2024/01/article)
[Download PDF](https://files.example.com/doc.pdf)
[Contact Support](mailto:support@example.com)
[Empty link]()
[Multiple words in link text](https://example.com/page)
[Special Ch@racters!](https://example.com/special)
[Nested [Brackets]](https://example.com)
[Numbers 123](https://123.example.com)
Here\'s some text [and another] thing (hello)';
my $regex = qr/\[.+?\]\(.+?\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}