import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.+?\\]\\(.+?\\)";
final String string = "[Click here for more info](https://example.com)\n"
+ "[Visit our website!](https://my.long.domain/path/to/something)[Latest news](https://news.site.com/2024/01/article)\n"
+ "[Download PDF](https://files.example.com/doc.pdf)\n"
+ "[Contact Support](mailto:support@example.com)\n"
+ "[Empty link]()\n"
+ "[Multiple words in link text](https://example.com/page)\n"
+ "[Special Ch@racters!](https://example.com/special)\n"
+ "[Nested [Brackets]](https://example.com)\n"
+ "[Numbers 123](https://123.example.com)\n\n"
+ "Here's some text [and another] thing (hello)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}