#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((([A-Za-z]+)(?:(?!\1).)+)\2+)"
Local $sString = "Hi hi missing u lollol hahahahalol sillybilly haaaaa!"
Local $sSubst = "\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)