use strict;
my $str = 'Hi hi missing u lollol hahahahalol sillybilly haaaaa!';
my $regex = qr/((([A-Za-z]+)(?:(?!\1).)+)\2+)/p;
my $subst = '\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";