import Foundation
let pattern = #"((([A-Za-z]+)(?:(?!\1).)+)\2+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hi hi missing u lollol hahahahalol sillybilly haaaaa!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)