$re = '/((([A-Za-z]+)(?:(?!\1).)+)\2+)/';
$str = 'Hi hi missing u lollol hahahahalol sillybilly haaaaa!';
$subst = "\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;