#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*[Rr]evert [^][]*\[\s*ID\d{3}\s*]).*\[\s*(ID\d{3})\s*\](.*)"
Local $sString = "Revert "[ID123] some cool feature." & @CRLF & _
"[ID123] some cool feature." & @CRLF & _
"some prefix [ID123] some cool feature"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")