import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*[Rr]evert [^][]*\\[\\s*ID\\d{3}\\s*]).*\\[\\s*(ID\\d{3})\\s*\\](.*)";
final String string = "Revert \"[ID123] some cool feature.\n"
+ "[ID123] some cool feature.\n"
+ "some prefix [ID123] some cool feature";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}