$re = '/^(?!.*[Rr]evert [^][]*\[\s*ID\d{3}\s*]).*\[\s*(ID\d{3})\s*\](.*)/m';
$str = 'Revert "[ID123] some cool feature.
[ID123] some cool feature.
some prefix [ID123] some cool feature';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);