re = /^(?!.*[Rr]evert [^][]*\[\s*ID\d{3}\s*]).*\[\s*(ID\d{3})\s*\](.*)/m
str = 'Revert "[ID123] some cool feature.
[ID123] some cool feature.
some prefix [ID123] some cool feature'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end