import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![\\u2764])[\\U00010000-\\U0010ffff]";
final String string = "This book is so funny❤️. This book 📖 is the bomb(AS IN THE BEST \n"
+ "IN THE WORLD 🌎 🌍🗺 )I love 💗 💕 💖 it!I definitely recommend it!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}