use strict;
my $str = 'This book is so funny❤️. This book 📖 is the bomb(AS IN THE BEST
IN THE WORLD 🌎 🌍🗺 )I love 💗 💕 💖 it!I definitely recommend it!';
my $regex = qr/(?![\u2764])[\U00010000-\U0010ffff]/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}