re = /(?![\u2764])[\U00010000-\U0010ffff]/m
str = 'This book is so funny❤️. This book 📖 is the bomb(AS IN THE BEST
IN THE WORLD 🌎 🌍🗺 )I love 💗 💕 💖 it!I definitely recommend it!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end