using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<product_identifier>[\w\d]+)-(?<major>\d+)\.(?<minor>\d+)-(?<feature_version>\d+)(-(?<support_release_suffix>\w+))?$";
string input = @"irma6r1-1.1-1
irma6r2-1.1-1
irma6r1-1.1-1-with_valid_support_suffix
irma6r2-1.1-1-with-invalid-support-suffix
irma6r2-1.1-with_missing_feature_version
irma6r1-1.0-1
matrix-1.0-1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}