import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<product_identifier>[\\w\\d]+)-(?<major>\\d+)\\.(?<minor>\\d+)-(?<feature_version>\\d+)(-(?<support_release_suffix>\\w+))?$";
final String string = "irma6r1-1.1-1\n"
+ "irma6r2-1.1-1\n"
+ "irma6r1-1.1-1-with_valid_support_suffix\n"
+ "irma6r2-1.1-1-with-invalid-support-suffix\n"
+ "irma6r2-1.1-with_missing_feature_version\n"
+ "irma6r1-1.0-1\n"
+ "matrix-1.0-1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}