import re
regex = re.compile(r"^(?<product_identifier>[\w\d]+)-(?<major>\d+)\.(?<minor>\d+)-(?<feature_version>\d+)(-(?<support_release_suffix>\w+))?$", flags=re.MULTILINE)
test_str = ("irma6r1-1.1-1\n"
"irma6r2-1.1-1\n"
"irma6r1-1.1-1-with_valid_support_suffix\n"
"irma6r2-1.1-1-with-invalid-support-suffix\n"
"irma6r2-1.1-with_missing_feature_version\n"
"irma6r1-1.0-1\n"
"matrix-1.0-1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")