re = /^(?<product_identifier>[\w\d]+)-(?<major>\d+)\.(?<minor>\d+)-(?<feature_version>\d+)(-(?<support_release_suffix>\w+))?$/m
str = 'irma6r1-1.1-1
irma6r2-1.1-1
irma6r1-1.1-1-with_valid_support_suffix
irma6r2-1.1-1-with-invalid-support-suffix
irma6r2-1.1-with_missing_feature_version
irma6r1-1.0-1
matrix-1.0-1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end