const regex = /(#\w{10})[\w\d]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#\\w{10})[\\w\\d]+', '')
const str = `var str = "The #dog is here, I need a #rest and this is not #availableeeeeeeee for now";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}