import Foundation
let pattern = ##"(#\w{10})[\w\d]+"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"var str = "The #dog is here, I need a #rest and this is not #availableeeeeeeee for now";"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}