re = /(#\w{10})[\w\d]+/
str = 'var str = "The #dog is here, I need a #rest and this is not #availableeeeeeeee for now";'
# Print the match result
str.match(re) do |match|
puts match.to_s
end