import re
regex = re.compile(r"(#\w{10})[\w\d]+")
test_str = "var str = \"The #dog is here, I need a #rest and this is not #availableeeeeeeee for now\";"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")