#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(?<func>[a-zA-Z_]\w+)\s*(\((?>[^()]+|(?2))*\))"
Local $sString = "var someVar = myValue; object.subob" & @CRLF & _
"ject.function(with, some = obj.func(a, b[2][1]), arguments); return true;" & @CRLF & _
"// or" & @CRLF & _
"var someVar = myValue; object.subobject.function(with, some = obj.fu" & @CRLF & _
"nc(a, b[2][1]), arguments); return true;" & @CRLF & _
"// or" & @CRLF & _
"var someVar = myValue; object.subobject.funct" & @CRLF & _
"ion(with, some = obj.func(a, b[2][1]), arguments); retun true;" & @CRLF & _
"// and so on"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")