using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<func>[a-zA-Z_]\w+)\s*(\((?>[^()]+|(?2))*\))";
string input = @"var someVar = myValue; object.subob
ject.function(with, some = obj.func(a, b[2][1]), arguments); return true;
// or
var someVar = myValue; object.subobject.function(with, some = obj.fu
nc(a, b[2][1]), arguments); return true;
// or
var someVar = myValue; object.subobject.funct
ion(with, some = obj.func(a, b[2][1]), arguments); retun true;
// and so on";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}