re = /(?<func>[a-zA-Z_]\w+)\s*(\((?>[^()]+|(?2))*\))/xm
str = 'var someVar = myValue; object.subob
ject.function(with, some = obj.func(a, b[2][1]), arguments); return true;
// or
var someVar = myValue; object.subobject.function(with, some = obj.fu
nc(a, b[2][1]), arguments); return true;
// or
var someVar = myValue; object.subobject.funct
ion(with, some = obj.func(a, b[2][1]), arguments); retun true;
// and so on'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end