using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.(?!((?=foo.*_.+)(?<!\"").*?\((?<!\""))))*$";
string input = @" CheckBarStatus(appHandle, ""fooBarApp_Lvds_init"", fooBarApp_Lvds_init(LVDS_CORE_RESOURCE, VI_TRUE, NULL, &appHandle), FUNCTION_CHECK_STOP_ON_FAIL);
output = fooBar_Config_GetInstrumentCount(&instrumentCount);
output = fooBar_init(resourceName, VI_FALSE, VI_TRUE, &vi);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}