re = /^(.(?!((?=foo.*_.+)(?<!\").*?\((?<!\"))))*$/
str = ' CheckBarStatus(appHandle, "fooBarApp_Lvds_init", fooBarApp_Lvds_init(LVDS_CORE_RESOURCE, VI_TRUE, NULL, &appHandle), FUNCTION_CHECK_STOP_ON_FAIL);
output = fooBar_Config_GetInstrumentCount(&instrumentCount);
output = fooBar_init(resourceName, VI_FALSE, VI_TRUE, &vi);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end