import re
regex = re.compile(r"^(.(?!((?=foo.*_.+)(?<!\").*?\((?<!\"))))*$")
test_str = (" CheckBarStatus(appHandle, \"fooBarApp_Lvds_init\", fooBarApp_Lvds_init(LVDS_CORE_RESOURCE, VI_TRUE, NULL, &appHandle), FUNCTION_CHECK_STOP_ON_FAIL);\n"
"output = fooBar_Config_GetInstrumentCount(&instrumentCount);\n"
"output = fooBar_init(resourceName, VI_FALSE, VI_TRUE, &vi);")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")