$re = '/^(.(?!((?=foo.*_.+)(?<!\").*?\((?<!\"))))*$/';
$str = ' CheckBarStatus(appHandle, "fooBarApp_Lvds_init", fooBarApp_Lvds_init(LVDS_CORE_RESOURCE, VI_TRUE, NULL, &appHandle), FUNCTION_CHECK_STOP_ON_FAIL);
output = fooBar_Config_GetInstrumentCount(&instrumentCount);
output = fooBar_init(resourceName, VI_FALSE, VI_TRUE, &vi);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);