using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ca[0-9_]+|[a-z]+\.csv";
string input = @"c://dev-dl-data-d2-us=east-1-5148727/all/stage/clinical/cro/raw/c/ca209_040/2018/08/02/aesae.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}