use strict;
my $str = 'c://dev-dl-data-d2-us=east-1-5148727/all/stage/clinical/cro/raw/c/ca209_040/2018/08/02/aesae.csv';
my $regex = qr/ca[0-9_]+|[a-z]+\.csv/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}