#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "servicepoint\W+(\w+)"
Local $sString = "servicepoint 200135644 watchid 7038842" & @CRLF & _
"watchid 7038842 servicepoint 200135644"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")