package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`servicepoint\W+(\w+)`)
var str = `servicepoint 200135644 watchid 7038842
watchid 7038842 servicepoint 200135644`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}