import Foundation
let pattern = #"servicepoint\W+(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
servicepoint 200135644 watchid 7038842
watchid 7038842 servicepoint 200135644
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}