const regex = /servicepoint\W+(\w+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('servicepoint\\W+(\\w+)', '')
const str = `servicepoint 200135644 watchid 7038842
watchid 7038842 servicepoint 200135644`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}