#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\()\(\((?!\().*?\)\)(?<!\)..)(?!\))"
Local $sString = "(pop((hello world))(goodbye(now))(hi)jump)" & @CRLF & _
"" & @CRLF & _
"(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)+889)+(241/242/275/550/551+882/889/362))" & @CRLF & _
"(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)(362/551/882)+889)+(241/242/275/550/551+882/889/362))" & @CRLF & _
"" & @CRLF & _
"(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)+889)+(241/242/275/550/551+882/889/362))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")