$re = '/(?<!\()\(\((?!\().*?\)\)(?<!\)..)(?!\))/m';
$str = '(pop((hello world))(goodbye(now))(hi)jump)
(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)+889)+(241/242/275/550/551+882/889/362))
(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)(362/551/882)+889)+(241/242/275/550/551+882/889/362))
(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)+889)+(241/242/275/550/551+882/889/362))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);