import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\()\\(\\((?!\\().*?\\)\\)(?<!\\)..)(?!\\))";
final String string = "(pop((hello world))(goodbye(now))(hi)jump)\n\n"
+ "(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)+889)+(241/242/275/550/551+882/889/362))\n"
+ "(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)(362/551/882)+889)+(241/242/275/550/551+882/889/362))\n\n"
+ "(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)+889)+(241/242/275/550/551+882/889/362))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}