use strict;
my $str = '(pop((hello world))(goodbye(now))(hi)jump)
(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)+889)+(241/242/275/550/551+882/889/362))
(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)(362/551/882)+889)+(241/242/275/550/551+882/889/362))
(M264/M274)+(((551/882)+362/(362/551/882)+889)/((551/882)+362/(362/551/882)+889)+(241/242/275/550/551+882/889/362))';
my $regex = qr/(?<!\()\(\((?!\().*?\)\)(?<!\)..)(?!\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}