using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(01)(\d{14}|\d{0})(21)(\d{10}|\d{0})";
string input = @"01050004560134822100000000091";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}